Modeling Gamma-Rays on your Birthday

Step 1: Download the data
1. Go to the HAWC Website (https://www.hawc-observatory.org/) and find the light curves data set to download. Save it to the desktop or a folder for the class
2. Right click and extract the files here, there should be four.
3. Right click on each file and rename it. Add “.txt” to the end of the file name. This allows the files to be uploaded to Google Sheets.
4. Open the file and take a look at it. It should look similar to this:
[image: ]
5. Locate the “Find and Replace” function. It is usually in a toolbar or under ‘Edit’. We need to change the format of the data to be more easily read by our SpreadSheet software.
6. Find all double space “  “ and replace them with a single space “ “. This will make the data uniform and should look similar to this:
[image: ]
7. Notice how the data and numbers are all the same distance apart? This makes it easy for the software to automatically create the spreadsheet.
8. You will need to do these steps for each data file. Do not change the Readme.
Step 2: Import the Data
1. We will need a fresh Google Sheet. Go to File > New > Spreadsheet and create a new blank spreadsheet.
2. Next open File > Import to import that data we just changed in Step 1. Click upload and find one of the files you changed.
3. Select Import location set to Insert new sheet(s), Separator type set to custom (put in a single space). Convert text to number, dates, and formulas set to Yes, and finally Select Import data. The import screen should look similar to this:
[image: ]
4. Once the data is in the program, it should look like this:
[image: ]
5. If each number is not in its own cell and lined up correctly, you either have to manually move them into place (so they are all in line similar to the data file you downloaded), or go back to the data file and continue replacing spaces tell it uploads correctly.
6. We now should adjust the header for each data column so that they match. Look to your data file to see what headers should go where. The order is as follows:

A should read MJD Start (Modified Julian Date)
B should read MJD Stop (Modified Julian Date)
C should read Flux + [SI] (HAWC Reading in photons/s*cm^2)
D should read -err [SI] (error in photons/s*cm^2)
E should read Flux + [CU] (HAWC Reading in Crab Units (Normalized to Crab Nebula))
F should read -err [CU] (error in Crab Units)
G should read Transits (% of observation time (quality of data set))
H should read Index (Unnecessary)
I should read Cut-off (Unnecessary)
J should read TS (bkg) (Higher value means higher significance over background noise)
7. Your spreadsheet should now look something like this:
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Step 3: The Readme File
1. Take a few minutes and read the Readme file that we extracted with the data files. This is the file that comes with the data to explain to scientists what they are looking at. Write down a few thoughts about the readme file. Look at the data in Google Sheets, does it make sense with what the Readme file says?

Step 4: Filter the data
1. You will notice we have a lot of data in the file. Not all of it is useful to us. As we read from the Readme file, the data in the Transits column represents how much data was collected that day. For this lesson, we only want data that has a transit of at least 0.80 (80%). We could go through the data individually and pull out the numbers with transit of at least 0.80, or we can have the spreadsheet program do that for us.
2. In the next available column (column K), next to the last data point (TS(bkg)), write the following function: =IF(G6>0.8,E6,” “)
3. This is an IF/THEN statement that tells the program to filter out data that does not have a transit value larger than 0.80. Check to see if it worked. Did a number appear in the cell? If so was it the same number that appears in Column E? If not is that because the value of column G was below 0.80? We want to take this function and apply it to the entire data set. Click on the cell and a box should appear in the bottom right corner. Click that box and drag it down until the entire data set is covered then release. Column K should be filled with data points EXCEPT when column G was less than 0.80.
4. It may be interesting to know what the average value was for the data. To do this click on the cell at the very bottom of column K’s data. In that cell write the following function: =AVERAGE(K6:K477). Google Sheets will take an average of all the data in the column. Make sure to label the average.
5. Finding the standard deviation of the data from the average is also useful. Below the average calculation write the following function: =STDEV(K6:K477). Again, label the standard deviation.
6. What can we interpret from knowing the average and standard deviation? Does the data vary widely? We will eventually be comparing this data set to two others.
7. Now we need to make a graph of the data. To do this highlight column K by clicking on it at the top of the spreadsheet. Once the column is selected go to Insert > Chart. A chart of the data will appear, try different chart types to find one that you think best represents the data. Make sure to properly label your chart as well. Your chart may look something like this:
[image: ]
8. What observations can you make about the data? How do the observations from the graph compare to your observations from the average and standard deviation?






Step 5: Create a Histogram to analyze the data
1. Create a new chart using the same steps in step 4, but make sure the chart type is a Histogram. Make sure to properly label your chart. The Histogram should look something like this:
[image: ]
2. A histogram tells you how often a number appears. We should expect it to make a bell shaped curve. What does the histogram of the data look like? Are there any unusual parts to it? What could it mean if measurements are larger than the bell curve? How common are these large values?

Step 6: Compare and Contrast
1. You now need to repeat all the previous steps for the other data files that you downloaded and extracted. The data needs to be uploaded, filtered, and the graphs evaluated.
2. Once you have all the graphs and analysis finished, look at and compare the results. How are the three alike? How are they different? 

Step 7: Gamma-Rays on your Birthday
1. Now we are going to attempt to determine how many Gamma-Rays were raining down on the earth on your birthday in 2015. First you should notice that the data does not have the dates in a form we are used to. They are written on a Modified Julian Calendar, which is commonly used by Astronomers. The calendar you are used to is what is known as the Gregorian Calendar, so we need to convert the date. Go to http://www.csgnetwork.com/julianmodifdateconv.html and convert your birthday to a Modified Julian date. Then scan through the data of each data set and find your birthday (congratulations!) We are interested in 3 days before and 3 days after the birthday, or around 7 days of measurements in total.
2. Add a new sheet by clicking the ‘+’ sign in the bottom left. Copy and paste the +flux and -err measurements IN [CU] UNITS to the new sheet for each data set. Make sure to label them so you know where each week of data came from.
3. We want to graph the data to see what happened around the week of your birthday. However we also need to worry about the error present in the measurements. This is where the -err data value is important. This value is one standard deviation on either side of the measurement. Meaning the actual value of the measurement may exist anywhere within the span of the error, either on the + side or the -. In scientific data, we show this error measurement with a bar on the graph, the length of the bar is equal to how spread out the measurement may actually be. 
4. Google Sheets is not yet good at applying error bars when the error on each measurement is different. So we need to force Google Sheets to create a graph in a way that allows us to plot separate error bars. We do this by taking the data and distributing it in a 7x7 array. Next to your birthday data set that you brought over to a fresh sheet create a row with 1-7 in each adjacent cell. Then create column to the left of the row and down a space going from 1 to 7 as well. This will create an array where you will have cells in row 1 correspond to column 1, 2, 3, etc across the sheet. In cell 1:1 (row 1 column 1) you will put the flux measurement from 3 days before your birthday. Cell 2:2 (row 2 column 2) will have 2 days before your birthday, and so on. Eventually all the birthday flux measurements will be in this new array you made. It should look something like this:
[image: ]
5. Now we can create a chart for the week of your birthday. Highlight the entire array, including both the measurements and the column and row numbers (1-7). Set the Chart type to Scatter.
6. Now you should have a scatterplot of your seven measurements. Right click on the chart and click ‘Chart Style’. Under ‘Customize’ open ‘Series’ and check the ‘Error Bars’ box. Your sheet should look something like this now:
[image: ]
7.  Now we can see small lines have been added to each data point. These are the error bars, but Google Sheets applies a uniform error to all measurements, we want them to be individual. Right under Series there is a drop down menu that says ‘Apply to all series’. Instead we want to change it to ‘Data Series 1’ so that we are only affecting the first data point (Cell 1:1 or 3 days before your birthday). The menu looks like this:
[image: ]
8. Once we have selected ‘Data Series 1’ we then go down to the error bar and change the ‘Type’ from ‘Percent’ to ‘Constant’ and the value to whatever the -err value was for that measurement. Your error bar should look similar to this:
[image: ]
9. Now that data series for 3 days before has the correct error bar. You know how precise that measurement is. Continue adding error bars for the rest of the data sets as well as creating graphs and error bars for the other two remaining data sets. Make sure to properly label your graphs.
Step 7: Interpreting the Data
1. Take a look at the three graphs you have created for the week surrounding your birthday in 2015. Are there any interesting observations that can be made? On your birthday was there a significant gamma ray emission? Does it seem as though the error of the measurements would affect the analysis? Was any one celestial object more active than another. Does this analysis hold true when considering the error of the measurements? How does the activity of these days compare with the averages and standard deviations you calculated?
Step 8: Publish your Results
1. Now it is time to publish the results! You need to show your findings off to the rest of the class. Just how exciting was your birthday in terms of Gamma-Rays? Create a poster/presentation/lab report that details how powerful the Gamma-Rays were on your birthday in 2015. The publication should include the steps taken to process the data, results, and interpretation.
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[ README x | [ HAWC_fluxlc_Mrk421_..._mintransits0.50.dat x

integration threshold: 2.00 Tev

#Crab flux > int. thresh: 6.103e-12

#redshift: 0.0000

#mininun-transit-coverage: 0.50

# MID start MID stop flux+/-err [cm-2 sn-1] flux+/-err [CU] transits index cut-off  Ts(bkg)
56988.4222 56988.5868  1.655e-11 4.043e-12  2.712 0.662  0.790  2.20 5.0 21.24

56989.4194 56989.6687  6.560e-12 3.309e-12  1.075 0.542  0.871  2.20 5.0 4.73
56990.4167 56990.6660  9.530e-12 3.457e-12  1.561 0.566  0.863  2.20 5.0 9.88
56991.4139 56991.6632  1.327e-11 3.708e-12  2.175 0.608  0.895  2.20 5.0 16.00
56992.4111 56992.6604  7.017e-12 3.296e-12  1.150 0.540  0.992  2.20 5.0 5.31
56993.4083 56993.5729  7.800e-12 3.446e-12  1.278 0.565  0.788  2.20 5.0 6.36
56994.4056 56994.6549  5.416e-12 2.991e-12  0.887 0.490  1.000  2.20 5.0 3.74
56995.4028 56995.6521  1.680e-11 3.592e-12  2.752 0.589  1.000  2.20 5.0 27.25
56996.4000 56996.6493  2.03le-11 3.856e-12  3.329 0.632  1.000  2.20 5.0 33.86
56997.3972 56997.6465  7.800e-12 3.272e-12  1.278 0.536  1.000  2.20 5.0 6.77
56998.3944 56998.6438  1.762e-11 3.733e-12  2.886 0.612  1.000  2.20 5.0 29.14
56999.3917 56999.6417  1.186e-11 3.238e-12  1.943 0.530  1.000  2.20 5.0 17.03
57000.3896 57000.6389  -8.46le-13 2.750e-12  -0.139 0.451  1.000  2.20 5.0 0.1
57001.3868 57001.6361  5.254e-12 3.346e-12  0.861 0.548  0.946  2.20 5.0 2.79
57002.3840 57002.6333  6.213e-12 3.329e-12  1.018 0.545  0.993  2.20 5.0 4.03
57003.3812 57003.6306  3.185e-12 3.198e-12  0.522 0.524  1.000  2.20 5.0 1.8
57004.3785 57004.6278  3.449%e-12 3.179e-12  0.565 0.521  1.000  2.20 5.0 1.26
57005.3757 57005.6250  8.556e-12 3.406e-12  1.402 ©.558  1.000  2.20 5.0 7.75
57006.3729 57006.6222  1.507e-11 4.074e-12  2.470 0.667  0.783  2.20 5.0 17.87
57007.3701 57007.5340  1.610e-11 3.830e-12  2.639 0.628  0.785  2.20 5.0 23.33
57008.3674 57008.5319  1.725e-11 4.100e-12  2.826 0.672  0.791  2.20 5.0 21.57
57009.3646 57009.6139  1.64le-11 3.596e-12  2.689 0.589  1.000  2.20 5.0 26.46
57010.3618 57010.6111  5.124e-12 3.247e-12  0.840 0.532  1.000  2.20 5.0 2.88
57011.3590 57011.6083  4.759e-12 3.060e-12  0.780 ©.501  1.000  2.20 5.0 2.83
57012.3562 57012.6056  1.587e-11 3.484e-12  2.601 0.571  1.000  2.20 5.0 28.83
57013.3535 57013.6028  1.137e-11 3.443e-12  1.862 0.564  0.968  2.20 5.0 13.48
57014.3514 57014.6007  1.965e-12 3.196e-12  ©0.322 0.524  1.000  2.20 5.0 0.40
57015.3486 57015.5979  6.932e-12 3.339e-12  1.136 0.547  0.994  2.20 5.0 5.05
57016.3458 57016.5951 -2.433e-12 2.884e-12  -0.399 0.473  0.934  2.20 5.0 0.86
57017.3431 57017.5924  1.245e-11 3.542e-12  2.041 0.580  0.922  2.20 5.0 16.06
57018.3403 57018.5896  5.962e-12 2.948e-12  0.977 0.483  1.000  2.20 5.0 5.06
57019.3375 57019.5868  7.398e-12 3.029e-12  1.212 0.496  1.000  2.20 5.0 7.15
57020.3347 57020.5840  2.905e-11 3.795e-12  4.759 ©.622  1.000  2.20 5.0 85.09
57021.3319 57021.5813  8.195e-12 3.125e-12  1.343 0.512  1.000  2.20 5.0 8.59
57022.3292 57022.5785  5.840e-12 3.090e-12  0.957 0.506  1.000  2.20 5.0 4.23
57023.3264 57023.5757  8.316e-12 3.390e-12  1.363 0.556  1.000  2.20 5.0 6.79
57024.3236 57024.5729  1.286e-11 3.326e-12  2.108 0.545  1.000  2.20 5.0 19.82
57025.3208 57025.5701  6.372e-12 3.020e-12  1.044 0.495  1.000  2.20 5.0 5.49
57026.3181 57026.5674  5.652e-12 3.187e-12  0.926 0.522  1.000  2.20 5.0 3.64
57027.3153 57027.5646  -4.129e-12 3.414e-12  -0.677 0.559  0.981  2.20 5.0 1.58
57028.3125 57028.5618  3.650e-12 3.215e-12  0.598 0.527  1.000  2.20 5.0 1.42
57029.3104 57029.5597  1.332e-11 3.506e-12  2.182 0.574  1.000  2.20 5.0 18.28
57030.3076 57030.5569  7.308e-12 3.548e-12  1.197 0.581  1.000  2.20 5.0 4.66
57031.3049 57031.5542  1.244e-11 3.457e-12  2.039 0.566  1.000  2.20 5.0 16.13
57032.3021 57032.5514  1.205e-11 3.398e-12  1.974 0.557  1.000  2.20 5.0 15.92
57033.2993 57033.5486  1.170e-11 3.397e-12  1.917 0.557  1.000  2.20 5.0 14.63
57034.2965 57034.5458 -1.082e-12 3.613e-12  -0.177 0.592  1.000  2.20 5.0 0.1
57035.2937 57035.5431  3.286e-12 2.874e-12  0.538 0.471  1.000  2.20 5.0 1.49

- PlainText + TabWidth:8 + Ln1,Col1 INS
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#integration threshold: 2.00 Tev
#Crab flux > int. thresh: 6.103e-12

HAWC_fluxlc_Mrk421_2014-11-26_2016-06-02_1days_si2.2_co5_int2.00TeV_mintransits0.50.dat.txt (~/Downloa...c_17months) - gedit
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